Overblog Folge diesem Blog
Edit post Administration Create my blog
Blog von Olaf Helper

Microsoft Visual Studio 2008 Express Edition: Welche .NET Framework Version?

12. Juni 2009 , Geschrieben von Olaf Helper Veröffentlicht in #.NET

Wenn man mit MS Visual Studio 2008 in Edition >= Standard ein neues Projekt anlegt, kann man über eine ComboBox auswählen, gegen welche Framework Version (also 2.0, 3.0, 3.5, Compact etc.) entwickeln und somit kompilieren möchte. Bei der Express Edition von MS Visual Studio 2008 Visual Basic / C# wird man nicht danach gefragt, es wird als Standard das .NET Framework 3.5 gesetzt.

Nun gibt es aber Projekte, die man gegen die Version 2.0 entwickeln will, z.B. Assemblies für den Microsoft SQL Server 2008 (dabei passen die Versionsnummer doch so schön ;-) ). Aber auch in der Express Edition von Visual Studio 2008 kann man es (nachträglich) angeben, es ist nur etwas sehr versteckt.

Zu finden ist es in den Projekt Eigenschaften unter dem Kartenreiter „Kompilieren“ über den Button „Erweiterte Kompilierungsoptionen…“. In dem folgenden Dialog kann man dann das „Zielframework“ auswählen.

Diesen Post teilen

Repost 0

Kommentiere diesen Post